Packet Tracer - DHCP dynamické přidělování adres

Datum vydání: 2015-06-03 18:09:32

Nastavení DHCP na serveru

Video pro lokální síť 192.168.2.0

Můj základní postup upravený pro lokální síť 192.168.1.0

  1. PC se zapojí do switche, switch se napojí na Server, vše se propojí kabelem Coper Straight-Through (interface FastEthernet0)
  2. Serveru se nastaví IP adresa (Config / INTERFACE / FastEthernet0 / Static IP adress 192.168.1.1)
  3. Serveru se nastaví DHCP (Config / SERVICES / DHCP / Service: ON, Start IP adress: 192.168.1.2, SAVE)
  4. Všem PC se nastaví dynamické přidělování adres (Desktop / PC configuration / DHCP)
  5. Poznámka: switch se nemusí nijak nastavovat.

Nastavení DHCP na routeru

Video pro síť 192.168.10.0

Vypsání základních příkazů z videa pro síť 192.168.10.0

Pro přehlednost jsem si přepsala zadávané příkazy ve videu bez použití zkratek:

Continue with configuration dialog? [yes/no]: no


Press RETURN to get started!



Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#host R1
R1(config)#interface fastethernet 0/0
R1(config-if)#ip address 192.168.10.1 255.255.255.0
R1(config-if)#no shutdown

R1(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R1(config-if)#exit
R1(config)#ip dhcp pool IP10
R1(dhcp-config)#network 192.168.10.0 255.255.255.0
R1(dhcp-config)#default 192.168.10.1
R1(dhcp-config)#exit
R1(config)#ip dhcp excluded-address 192.168.10.1 192.168.10.10
R1(config)#exit
R1#
%SYS-5-CONFIG_I: Configured from console by console
R1#copy run start
Destination filename [startup-config]? 
Building configuration...
[OK]
R1#show running-config
Building configuration...

.
.
.

R1#exit

Můj výše upravený příklad pro síť 192.168.1.0

Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface fastethernet 0/0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#exit
Router(config)#ip dhcp pool mypool
Router(dhcp-config)#network 192.168.1.0 255.255.255.0
Router(dhcp-config)#default 192.168.1.1
Router(dhcp-config)#exit
Router(config)#ip dhcp excluded-address 192.168.1.1 192.168.1.1
Router(config)#exit
Router#
%SYS-5-CONFIG_I: Configured from console by console

Router#copy run start
Destination filename [startup-config]? 
Building configuration...
[OK]
Router#show running-config
Building configuration...

.
.
.

Router#exit

Můj základní postup upravený pro lokální síť 192.168.1.0

  1. PC se zapojí do switche, switch se napojí na router, vše se propojí kabelem Coper Straight-Through (interface FastEthernet0)
  2. Routeru na FastEthernet0/0 se nastaví IP adresa pomocí příkazového řádku CLI na 192.168.1.1, a to příkazem ip address (zároveň půjde o výchozí bránu, nastaveno příkazem default) a provede se další ruční konfigurace rozsahu adres a sítě. Konfigurace se musí uložit.
  3. Všem PC se nastaví dynamické přidělování adres (Desktop / PC configuration / DHCP)
  4. Poznámka: switch se nemusí nijak nastavovat.

Video od ciscoccnatutorials

Návody a dokumentace

Užitečné příkazy:

show ip interface brief

Statické přidělování adres

Vyhledávání

Články na ITčku: